Getting SPCC to work

I am doing something wrong with SPCC. I can never get the image solver to work. In my current try I have an image of M101. I have the Gaia DR3 files configured and I can solve with the PI script but AutoIntegrate fails to solve. I tried solving external to AI and generated WCS files for the LRGB masters and unset the solve and set he SPCC flag and AI still tries to solve. I still get the error:

Matching stars: done

102 putative star pair matches.

Performing RANSAC: done

*** Error: Unable to find an initial set of putative star pair matches.

<* failed *>

*** Error: The image could not be aligned with the reference star field.

Please check the following items:

  • The initial coordinates should be inside the image.
  • The initial resolution should be within a factor of 2 from the correct value.
  • If you use an online star catalog through the VizieR service, consider using the Gaia DR3 catalog with local XPSD databases instead.
  • If the image has high noise levels, bad tracking, or is poorly focused, you may need to adjust some star detection parameters.

*** Error: Unable to plate solve image: Alignment failed.

This usually happens because the initial parameters are too far from the actual metadata of the image.

runImageSolver: SolveImage failed

Focal length: 863

Resolution: 0.8986740109954605

ImageSolver failed

AutoIntegrate: ImageSolver retry with stretched image failed

Error: ImageSolver retry with stretched image failed

Processing stopped!


Hi Kurt,

SPCC is complex, and debugging is even more complex. At least for me. Obviously it should work but at first I have only questions:

Do these values match with your setup?
Focal length: 863
Resolution: 0.8986740109954605

Is it possible to send me a test image so I can try it myself? Just a single FITS file should be enough.


Just to conclude this thread, there were two problems:

  • Alignment problem was fixed by solving the image again. In the AutoIntegrate v1.66 there is option to force solving event if previous solving is done. It is unclear why solving again fixed the problem, maybe some metadata compatibility problem.
  • There was a but when using AutoIntegrate with an older PixInsight version. This is fixed in v1.66